import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9])\\/[1-9][0-9]$";
final String string = "2225/35\n"
+ "2/25\n"
+ "123/12\n"
+ "4321/56\n"
+ "/22\n"
+ "0/00\n"
+ "0145/36\n"
+ "1234\n"
+ "5215\n"
+ "2036\n\n"
+ "256314\n"
+ "123456\n"
+ "654321\n"
+ "102365\n\n"
+ "123456\n"
+ "19\n"
+ "222222/12\n"
+ "256314/21\n\n"
+ "256314/21\n"
+ "06314/21\n\n\n\n"
+ "52634125/25\n"
+ "025636/65\n\n"
+ "025253\n"
+ "253641\n\n"
+ "19\n"
+ "01\n\n"
+ "123\n"
+ "032\n\n"
+ "1234\n"
+ "0325\n"
+ "123456\n"
+ "036254\n\n"
+ "965236\n"
+ "095325\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}