# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9])\/[1-9][0-9]$"
test_str = ("2225/35\n"
"2/25\n"
"123/12\n"
"4321/56\n"
"/22\n"
"0/00\n"
"0145/36\n"
"1234\n"
"5215\n"
"2036\n\n"
"256314\n"
"123456\n"
"654321\n"
"102365\n\n"
"123456\n"
"19\n"
"222222/12\n"
"256314/21\n\n"
"256314/21\n"
"06314/21\n\n\n\n"
"52634125/25\n"
"025636/65\n\n"
"025253\n"
"253641\n\n"
"19\n"
"01\n\n"
"123\n"
"032\n\n"
"1234\n"
"0325\n"
"123456\n"
"036254\n\n"
"965236\n"
"095325\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.