re = /^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9])\/[1-9][0-9]$/m
str = '2225/35
2/25
123/12
4321/56
/22
0/00
0145/36
1234
5215
2036
256314
123456
654321
102365
123456
19
222222/12
256314/21
256314/21
06314/21
52634125/25
025636/65
025253
253641
19
01
123
032
1234
0325
123456
036254
965236
095325
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end