using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9])\/[1-9][0-9]$";
string input = @"2225/35
2/25
123/12
4321/56
/22
0/00
0145/36
1234
5215
2036
256314
123456
654321
102365
123456
19
222222/12
256314/21
256314/21
06314/21
52634125/25
025636/65
025253
253641
19
01
123
032
1234
0325
123456
036254
965236
095325
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}