re = /([A-z])((?![A-z]{2,3}$)\w){2,3}/m
str = 'Bt12
bt12
bte2
bt1
b123
b12
Bte
1bt
123
b1
abcd
12
ab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end