#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-z])((?![A-z]{2,3}$)\w){2,3}"
Local $sString = "Bt12" & @CRLF & _
"bt12" & @CRLF & _
"bte2" & @CRLF & _
"bt1" & @CRLF & _
"b123" & @CRLF & _
"b12" & @CRLF & _
"" & @CRLF & _
"Bte" & @CRLF & _
"1bt" & @CRLF & _
"123" & @CRLF & _
"b1" & @CRLF & _
"abcd" & @CRLF & _
"12" & @CRLF & _
"ab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")