const regex = /([A-z])((?![A-z]{2,3}$)\w){2,3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-z])((?![A-z]{2,3}$)\\w){2,3}', 'gm')
const str = `Bt12
bt12
bte2
bt1
b123
b12
Bte
1bt
123
b1
abcd
12
ab`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}