use strict;
my $str = 'Bt12
bt12
bte2
bt1
b123
b12
Bte
1bt
123
b1
abcd
12
ab';
my $regex = qr/([A-z])((?![A-z]{2,3}$)\w){2,3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}