using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-z])((?![A-z]{2,3}$)\w){2,3}";
string input = @"Bt12
bt12
bte2
bt1
b123
b12
Bte
1bt
123
b1
abcd
12
ab";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}