import Foundation
let pattern = #"(?:\"(?:errorType)\"(?:[^:])*):(?:(?:[^\",])*)\"([^\"]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"data": null,
"errors": [
{
"message": "Message",
"extensions": {
"errorType": "UNKNOWN",
"error_code": "AUTHENTICATE_USER_FALSE"
}
},
{
"message": "Message",
"extensions": {
"errorType": "UNAUTHENTICATED",
"error_code": "AUTHENTICATE_USER_FALSE"
}
}
]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)