re = /(?:\"(?:errorType)\"(?:[^:])*):(?:(?:[^\",])*)\"([^\"]*)/
str = '{
"data": null,
"errors": [
{
"message": "Message",
"extensions": {
"errorType": "UNKNOWN",
"error_code": "AUTHENTICATE_USER_FALSE"
}
},
{
"message": "Message",
"extensions": {
"errorType": "UNAUTHENTICATED",
"error_code": "AUTHENTICATE_USER_FALSE"
}
}
]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end