$re = '/(?:\"(?:errorType)\"(?:[^:])*):(?:(?:[^\",])*)\"([^\"]*)/';
$str = '{
"data": null,
"errors": [
{
"message": "Message",
"extensions": {
"errorType": "UNKNOWN",
"error_code": "AUTHENTICATE_USER_FALSE"
}
},
{
"message": "Message",
"extensions": {
"errorType": "UNAUTHENTICATED",
"error_code": "AUTHENTICATE_USER_FALSE"
}
}
]
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);