package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\"(?:errorType)\"(?:[^:])*):(?:(?:[^\",])*)\"([^\"]*)`)
var str = `{
"data": null,
"errors": [
{
"message": "Message",
"extensions": {
"errorType": "UNKNOWN",
"error_code": "AUTHENTICATE_USER_FALSE"
}
},
{
"message": "Message",
"extensions": {
"errorType": "UNAUTHENTICATED",
"error_code": "AUTHENTICATE_USER_FALSE"
}
}
]
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}