#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\"(?:errorType)\"(?:[^:])*):(?:(?:[^\",])*)\"([^\"]*)"
Local $sString = "{" & @CRLF & _
" "data": null," & @CRLF & _
" "errors": [" & @CRLF & _
" {" & @CRLF & _
" "message": "Message"," & @CRLF & _
" "extensions": {" & @CRLF & _
" "errorType": "UNKNOWN"," & @CRLF & _
" "error_code": "AUTHENTICATE_USER_FALSE"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "message": "Message"," & @CRLF & _
" "extensions": {" & @CRLF & _
" "errorType": "UNAUTHENTICATED"," & @CRLF & _
" "error_code": "AUTHENTICATE_USER_FALSE"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")