re = /^(?:(https?):)?(\/\/.*\.[^\/]+)$/m
str = 'Regex for http:/https: or only domain url stating with a slash
Examples:
https://example.domain
http://example.domain
//example.domain
//example.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end