const regex = /^(?:(https?):)?(\/\/.*\.[^\/]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(https?):)?(\\\/\\\/.*\\.[^\\\/]+)$', 'gm')
const str = `Regex for http:/https: or only domain url stating with a slash
Examples:
https://example.domain
http://example.domain
//example.domain
//example.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}