#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(https?):)?(\/\/.*\.[^\/]+)$"
Local $sString = "Regex for http:/https: or only domain url stating with a slash" & @CRLF & _
"" & @CRLF & _
"Examples:" & @CRLF & _
"https://example.domain" & @CRLF & _
"http://example.domain" & @CRLF & _
"//example.domain" & @CRLF & _
"//example.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")