$re = '/^(?:(https?):)?(\/\/.*\.[^\/]+)$/m';
$str = 'Regex for http:/https: or only domain url stating with a slash
Examples:
https://example.domain
http://example.domain
//example.domain
//example.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);