import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(https?):)?(\\/\\/.*\\.[^\\/]+)$";
final String string = "Regex for http:/https: or only domain url stating with a slash\n\n"
+ "Examples:\n"
+ "https://example.domain\n"
+ "http://example.domain\n"
+ "//example.domain\n"
+ "//example.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}