import Foundation
let pattern = #"(images\/.+)((?<!no-compress)\.png|\.jpeg|\.jpg|\.PNG|\.JPEG|\.JPG)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
images/dwaudhawd_Test Picture.png
images/dwaudhawd_Test Picture no-compress.png
images/suman.JPEG
images/maharjan.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.webp"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)