# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(images\\/.+)((?<!no-compress)\.png|\.jpeg|\.jpg|\.PNG|\.JPEG|\.JPG)/$1.webp/gm;t' <<< "images/dwaudhawd_Test Picture.png
images/dwaudhawd_Test Picture no-compress.png
images/suman.JPEG
images/maharjan.jpg"