const regex = /(images\/.+)((?<!no-compress)\.png|\.jpeg|\.jpg|\.PNG|\.JPEG|\.JPG)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(images\\\/.+)((?<!no-compress)\\.png|\\.jpeg|\\.jpg|\\.PNG|\\.JPEG|\\.JPG)', 'gm')
const str = `images/dwaudhawd_Test Picture.png
images/dwaudhawd_Test Picture no-compress.png
images/suman.JPEG
images/maharjan.jpg`;
const subst = `$1.webp`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);