use strict;
my $str = 'images/dwaudhawd_Test Picture.png
images/dwaudhawd_Test Picture no-compress.png
images/suman.JPEG
images/maharjan.jpg';
my $regex = qr/(images\/.+)((?<!no-compress)\.png|\.jpeg|\.jpg|\.PNG|\.JPEG|\.JPG)/mp;
my $subst = '$1.webp';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";