# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(images\/.+)((?<!no-compress)\.png|\.jpeg|\.jpg|\.PNG|\.JPEG|\.JPG)"
test_str = ("images/dwaudhawd_Test Picture.png\n"
"images/dwaudhawd_Test Picture no-compress.png\n"
"images/suman.JPEG\n"
"images/maharjan.jpg")
subst = "$1.webp"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.