import Foundation
let pattern = #"^([A-Za-z]*)(-)([0-9]*)(.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"pouy-78-1_viuelsov-boltespmer_1.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)