# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([A-Za-z]*)(-)([0-9]*)(.+)$/\3/gm;t' <<< "pouy-78-1_viuelsov-boltespmer_1.pdf"