$re = '/^([A-Za-z]*)(-)([0-9]*)(.+)$/m';
$str = 'pouy-78-1_viuelsov-boltespmer_1.pdf';
$subst = "\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;