using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Za-z]*)(-)([0-9]*)(.+)$";
string substitution = @"\3";
string input = @"pouy-78-1_viuelsov-boltespmer_1.pdf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}