// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z]*)(-)([0-9]*)(.+)$").unwrap();
let string = "pouy-78-1_viuelsov-boltespmer_1.pdf";
let substitution = "\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}