// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\/+(www\.|\w+.)?\w+\.\w+").unwrap();
let string = "https://www.google.com
http://coreyms.com
https://youtube.com
https://www.nasa.gov
CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net
abcdefghijklmnopqurtuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
1234567890
Ha HaHa
MetaCharacters (Need to be escaped):
.[{()\\^$|?*+
coreyms.com
321-555-4321
123.555.1234
123*555*1234
800-555-4321
900-555-4321
Mr. Schafer
Mr Smith
Ms Davis
Mrs. Robinson
Mr. T
cat
mat
pat
bat
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}