import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/+(www\\.|\\w+.)?\\w+\\.\\w+";
final String string = "https://www.google.com\n"
+ "http://coreyms.com\n"
+ "https://youtube.com\n"
+ "https://www.nasa.gov\n\n"
+ "CoreyMSchafer@gmail.com\n"
+ "corey.schafer@university.edu\n"
+ "corey-321-schafer@my-work.net\n\n"
+ "abcdefghijklmnopqurtuvwxyz\n"
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
+ "1234567890\n\n"
+ "Ha HaHa\n\n"
+ "MetaCharacters (Need to be escaped):\n"
+ ".[{()\\^$|?*+\n\n"
+ "coreyms.com\n\n"
+ "321-555-4321\n"
+ "123.555.1234\n"
+ "123*555*1234\n"
+ "800-555-4321\n"
+ "900-555-4321\n\n\n"
+ "Mr. Schafer\n"
+ "Mr Smith\n"
+ "Ms Davis\n"
+ "Mrs. Robinson\n"
+ "Mr. T\n\n"
+ "cat\n"
+ "mat\n"
+ "pat\n"
+ "bat\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}