$re = '/https?:\/+(www\.|\w+.)?\w+\.\w+/m';
$str = 'https://www.google.com
http://coreyms.com
https://youtube.com
https://www.nasa.gov
CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net
abcdefghijklmnopqurtuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
1234567890
Ha HaHa
MetaCharacters (Need to be escaped):
.[{()\\^$|?*+
coreyms.com
321-555-4321
123.555.1234
123*555*1234
800-555-4321
900-555-4321
Mr. Schafer
Mr Smith
Ms Davis
Mrs. Robinson
Mr. T
cat
mat
pat
bat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);