#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/+(www\.|\w+.)?\w+\.\w+"
Local $sString = "https://www.google.com" & @CRLF & _
"http://coreyms.com" & @CRLF & _
"https://youtube.com" & @CRLF & _
"https://www.nasa.gov" & @CRLF & _
"" & @CRLF & _
"CoreyMSchafer@gmail.com" & @CRLF & _
"corey.schafer@university.edu" & @CRLF & _
"corey-321-schafer@my-work.net" & @CRLF & _
"" & @CRLF & _
"abcdefghijklmnopqurtuvwxyz" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"1234567890" & @CRLF & _
"" & @CRLF & _
"Ha HaHa" & @CRLF & _
"" & @CRLF & _
"MetaCharacters (Need to be escaped):" & @CRLF & _
".[{()\^$|?*+" & @CRLF & _
"" & @CRLF & _
"coreyms.com" & @CRLF & _
"" & @CRLF & _
"321-555-4321" & @CRLF & _
"123.555.1234" & @CRLF & _
"123*555*1234" & @CRLF & _
"800-555-4321" & @CRLF & _
"900-555-4321" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Mr. Schafer" & @CRLF & _
"Mr Smith" & @CRLF & _
"Ms Davis" & @CRLF & _
"Mrs. Robinson" & @CRLF & _
"Mr. T" & @CRLF & _
"" & @CRLF & _
"cat" & @CRLF & _
"mat" & @CRLF & _
"pat" & @CRLF & _
"bat" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")