# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?:\/+(www\.|\w+.)?\w+\.\w+"
test_str = ("https://www.google.com\n"
"http://coreyms.com\n"
"https://youtube.com\n"
"https://www.nasa.gov\n\n"
"CoreyMSchafer@gmail.com\n"
"corey.schafer@university.edu\n"
"corey-321-schafer@my-work.net\n\n"
"abcdefghijklmnopqurtuvwxyz\n"
"ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
"1234567890\n\n"
"Ha HaHa\n\n"
"MetaCharacters (Need to be escaped):\n"
".[{()\\^$|?*+\n\n"
"coreyms.com\n\n"
"321-555-4321\n"
"123.555.1234\n"
"123*555*1234\n"
"800-555-4321\n"
"900-555-4321\n\n\n"
"Mr. Schafer\n"
"Mr Smith\n"
"Ms Davis\n"
"Mrs. Robinson\n"
"Mr. T\n\n"
"cat\n"
"mat\n"
"pat\n"
"bat\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.