import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^(?<streetName>.*?)(\s((nr|n|no)\.?\s*)?(?<houseNumber>[1-9][0-9]*)(\s*[-\/]\s*(?<houseNumberTo>[1-9][0-9]*))?([\s-\/]*(?<houseLetter>[a-z]))?([\s\-]+(?<houseNumberAddition>[a-z1-9][a-z0-9\/]*[a-z]+))?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Geldersekade 5
Prins Hendrikkade 94-95
Zeedijk 39 a
Prins Hendrikkade 85
Kromme Waal 24 t/o
Oude Waal 26 sous
Recht Boomssloot 50-b
Oudeschans 5a
Blaak 5a
çstraét 12
Æbçøüdéstrāßè 12
binnenbantammer straat n.2
Oudezijds Voorburgwal 36-HS
De Ruijterkade 105 1S
De Ruijterkade 110H
Prins Hendrikkade 133 3A
Plein 1818 2a
Scheveningseveer 21
De Stelling 15 11
Plein ’40-’45 nr. 9
Burg.de Vlugtlaan 139
Plein ‘40-’45 6
Plein 18 1
Plein 1953 2
Plein 1953 28
Plein 1337 4-c
Plein 1337 4 1d
Regulieersdwarsstraat 5-1
Regulieersdwarsstraat 5-1c
Regulieersdwarsstraat 5 1x
Rechte boom straat 5001 33
Plein 2001 22-44
Plein1234 4
Hesseplaats 53
1e middellandstraat 12
Prins Hendrikkade 4/A
Langerakplein 22/44
Roer 266
3 Spinel
Roer
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)