#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?imu)^(?<streetName>.*?)(\s((nr|n|no)\.?\s*)?(?<houseNumber>[1-9][0-9]*)(\s*[-\/]\s*(?<houseNumberTo>[1-9][0-9]*))?([\s-\/]*(?<houseLetter>[a-z]))?([\s\-]+(?<houseNumberAddition>[a-z1-9][a-z0-9\/]*[a-z]+))?)?$"
Local $sString = "Geldersekade 5" & @CRLF & _
"Prins Hendrikkade 94-95" & @CRLF & _
"Zeedijk 39 a" & @CRLF & _
"Prins Hendrikkade 85" & @CRLF & _
"Kromme Waal 24 t/o" & @CRLF & _
"Oude Waal 26 sous" & @CRLF & _
"Recht Boomssloot 50-b" & @CRLF & _
"Oudeschans 5a" & @CRLF & _
"Blaak 5a" & @CRLF & _
"çstraét 12" & @CRLF & _
"Æbçøüdéstrāßè 12" & @CRLF & _
"binnenbantammer straat n.2" & @CRLF & _
"Oudezijds Voorburgwal 36-HS" & @CRLF & _
"De Ruijterkade 105 1S" & @CRLF & _
"De Ruijterkade 110H" & @CRLF & _
"Prins Hendrikkade 133 3A" & @CRLF & _
"Plein 1818 2a" & @CRLF & _
"Scheveningseveer 21" & @CRLF & _
"De Stelling 15 11" & @CRLF & _
"Plein ’40-’45 nr. 9" & @CRLF & _
"Burg.de Vlugtlaan 139" & @CRLF & _
"Plein ‘40-’45 6" & @CRLF & _
"Plein 18 1" & @CRLF & _
"Plein 1953 2" & @CRLF & _
"Plein 1953 28" & @CRLF & _
"Plein 1337 4-c" & @CRLF & _
"Plein 1337 4 1d" & @CRLF & _
"Regulieersdwarsstraat 5-1" & @CRLF & _
"Regulieersdwarsstraat 5-1c" & @CRLF & _
"Regulieersdwarsstraat 5 1x" & @CRLF & _
"Rechte boom straat 5001 33" & @CRLF & _
"Plein 2001 22-44" & @CRLF & _
"Plein1234 4" & @CRLF & _
"Hesseplaats 53" & @CRLF & _
"1e middellandstraat 12" & @CRLF & _
"Prins Hendrikkade 4/A" & @CRLF & _
"Langerakplein 22/44 " & @CRLF & _
"Roer 266" & @CRLF & _
"3 Spinel" & @CRLF & _
"Roer" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")