import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<streetName>.*?)(\\s((nr|n|no)\\.?\\s*)?(?<houseNumber>[1-9][0-9]*)(\\s*[-\\/]\\s*(?<houseNumberTo>[1-9][0-9]*))?([\\s-\\/]*(?<houseLetter>[a-z]))?([\\s\\-]+(?<houseNumberAddition>[a-z1-9][a-z0-9\\/]*[a-z]+))?)?$";
final String string = "Geldersekade 5\n"
+ "Prins Hendrikkade 94-95\n"
+ "Zeedijk 39 a\n"
+ "Prins Hendrikkade 85\n"
+ "Kromme Waal 24 t/o\n"
+ "Oude Waal 26 sous\n"
+ "Recht Boomssloot 50-b\n"
+ "Oudeschans 5a\n"
+ "Blaak 5a\n"
+ "çstraét 12\n"
+ "Æbçøüdéstrāßè 12\n"
+ "binnenbantammer straat n.2\n"
+ "Oudezijds Voorburgwal 36-HS\n"
+ "De Ruijterkade 105 1S\n"
+ "De Ruijterkade 110H\n"
+ "Prins Hendrikkade 133 3A\n"
+ "Plein 1818 2a\n"
+ "Scheveningseveer 21\n"
+ "De Stelling 15 11\n"
+ "Plein ’40-’45 nr. 9\n"
+ "Burg.de Vlugtlaan 139\n"
+ "Plein ‘40-’45 6\n"
+ "Plein 18 1\n"
+ "Plein 1953 2\n"
+ "Plein 1953 28\n"
+ "Plein 1337 4-c\n"
+ "Plein 1337 4 1d\n"
+ "Regulieersdwarsstraat 5-1\n"
+ "Regulieersdwarsstraat 5-1c\n"
+ "Regulieersdwarsstraat 5 1x\n"
+ "Rechte boom straat 5001 33\n"
+ "Plein 2001 22-44\n"
+ "Plein1234 4\n"
+ "Hesseplaats 53\n"
+ "1e middellandstraat 12\n"
+ "Prins Hendrikkade 4/A\n"
+ "Langerakplein 22/44 \n"
+ "Roer 266\n"
+ "3 Spinel\n"
+ "Roer\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}