# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<streetName>.*?)(\s((nr|n|no)\.?\s*)?(?<houseNumber>[1-9][0-9]*)(\s*[-\/]\s*(?<houseNumberTo>[1-9][0-9]*))?([\s-\/]*(?<houseLetter>[a-z]))?([\s\-]+(?<houseNumberAddition>[a-z1-9][a-z0-9\/]*[a-z]+))?)?$"
test_str = ("Geldersekade 5\n"
"Prins Hendrikkade 94-95\n"
"Zeedijk 39 a\n"
"Prins Hendrikkade 85\n"
"Kromme Waal 24 t/o\n"
"Oude Waal 26 sous\n"
"Recht Boomssloot 50-b\n"
"Oudeschans 5a\n"
"Blaak 5a\n"
"çstraét 12\n"
"Æbçøüdéstrāßè 12\n"
"binnenbantammer straat n.2\n"
"Oudezijds Voorburgwal 36-HS\n"
"De Ruijterkade 105 1S\n"
"De Ruijterkade 110H\n"
"Prins Hendrikkade 133 3A\n"
"Plein 1818 2a\n"
"Scheveningseveer 21\n"
"De Stelling 15 11\n"
"Plein ’40-’45 nr. 9\n"
"Burg.de Vlugtlaan 139\n"
"Plein ‘40-’45 6\n"
"Plein 18 1\n"
"Plein 1953 2\n"
"Plein 1953 28\n"
"Plein 1337 4-c\n"
"Plein 1337 4 1d\n"
"Regulieersdwarsstraat 5-1\n"
"Regulieersdwarsstraat 5-1c\n"
"Regulieersdwarsstraat 5 1x\n"
"Rechte boom straat 5001 33\n"
"Plein 2001 22-44\n"
"Plein1234 4\n"
"Hesseplaats 53\n"
"1e middellandstraat 12\n"
"Prins Hendrikkade 4/A\n"
"Langerakplein 22/44 \n"
"Roer 266\n"
"3 Spinel\n"
"Roer\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.