const regex = /^(?<streetName>.*?)(\s((nr|n|no)\.?\s*)?(?<houseNumber>[1-9][0-9]*)(\s*[-\/]\s*(?<houseNumberTo>[1-9][0-9]*))?([\s-\/]*(?<houseLetter>[a-z]))?([\s\-]+(?<houseNumberAddition>[a-z1-9][a-z0-9\/]*[a-z]+))?)?$/imgu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<streetName>.*?)(\\s((nr|n|no)\\.?\\s*)?(?<houseNumber>[1-9][0-9]*)(\\s*[-\\\/]\\s*(?<houseNumberTo>[1-9][0-9]*))?([\\s-\\\/]*(?<houseLetter>[a-z]))?([\\s\\-]+(?<houseNumberAddition>[a-z1-9][a-z0-9\\\/]*[a-z]+))?)?$', 'imgu')
const str = `Geldersekade 5
Prins Hendrikkade 94-95
Zeedijk 39 a
Prins Hendrikkade 85
Kromme Waal 24 t/o
Oude Waal 26 sous
Recht Boomssloot 50-b
Oudeschans 5a
Blaak 5a
çstraét 12
Æbçøüdéstrāßè 12
binnenbantammer straat n.2
Oudezijds Voorburgwal 36-HS
De Ruijterkade 105 1S
De Ruijterkade 110H
Prins Hendrikkade 133 3A
Plein 1818 2a
Scheveningseveer 21
De Stelling 15 11
Plein ’40-’45 nr. 9
Burg.de Vlugtlaan 139
Plein ‘40-’45 6
Plein 18 1
Plein 1953 2
Plein 1953 28
Plein 1337 4-c
Plein 1337 4 1d
Regulieersdwarsstraat 5-1
Regulieersdwarsstraat 5-1c
Regulieersdwarsstraat 5 1x
Rechte boom straat 5001 33
Plein 2001 22-44
Plein1234 4
Hesseplaats 53
1e middellandstraat 12
Prins Hendrikkade 4/A
Langerakplein 22/44
Roer 266
3 Spinel
Roer
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}