# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?'protocol'[a-z]{2,}(?=[:])):)?(?:\/\/)?(?:(?'subdomain'(?:[0-9a-z](?![\-\.]))+(?:[0-9a-z\-\.][0-9a-z]+)+?)\.(?'domain'(?:[0-9a-z](?![\-]))+(?:[0-9a-z\-][0-9a-z])\.(?'tld'[a-z]{2,}(?:\.[a-z]{2})?))|(?'ip'(?'segment'[01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9])\.(?&segment)\.(?&segment)\.(?&segment)))(?:\:(?'port'\d+))?(?'path'(?:\/[^\/\?]*?)*)?(?:\?(?'query'[^#]*))?(?:#!?(?'hash'.*))?$"
test_str = ("ftp://regex101.billy.com.uk:3000/test/blah?hello=blah&#!/blah/blue/green\n"
"https://192.168.1.1/test/lab")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.