using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?'protocol'[a-z]{2,}(?=[:])):)?(?:\/\/)?(?:(?'subdomain'(?:[0-9a-z](?![\-\.]))+(?:[0-9a-z\-\.][0-9a-z]+)+?)\.(?'domain'(?:[0-9a-z](?![\-]))+(?:[0-9a-z\-][0-9a-z])\.(?'tld'[a-z]{2,}(?:\.[a-z]{2})?))|(?'ip'(?'segment'[01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9])\.(?&segment)\.(?&segment)\.(?&segment)))(?:\:(?'port'\d+))?(?'path'(?:\/[^\/\?]*?)*)?(?:\?(?'query'[^#]*))?(?:#!?(?'hash'.*))?$";
string input = @"ftp://regex101.billy.com.uk:3000/test/blah?hello=blah&#!/blah/blue/green
https://192.168.1.1/test/lab";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}