import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?'protocol'[a-z]{2,}(?=[:])):)?(?:\\/\\/)?(?:(?'subdomain'(?:[0-9a-z](?![\\-\\.]))+(?:[0-9a-z\\-\\.][0-9a-z]+)+?)\\.(?'domain'(?:[0-9a-z](?![\\-]))+(?:[0-9a-z\\-][0-9a-z])\\.(?'tld'[a-z]{2,}(?:\\.[a-z]{2})?))|(?'ip'(?'segment'[01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9])\\.(?&segment)\\.(?&segment)\\.(?&segment)))(?:\\:(?'port'\\d+))?(?'path'(?:\\/[^\\/\\?]*?)*)?(?:\\?(?'query'[^#]*))?(?:#!?(?'hash'.*))?$";
final String string = "ftp://regex101.billy.com.uk:3000/test/blah?hello=blah&#!/blah/blue/green\n"
+ "https://192.168.1.1/test/lab";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}