const regex = /^(?:(?'protocol'[a-z]{2,}(?=[:])):)?(?:\/\/)?(?:(?'subdomain'(?:[0-9a-z](?![\-\.]))+(?:[0-9a-z\-\.][0-9a-z]+)+?)\.(?'domain'(?:[0-9a-z](?![\-]))+(?:[0-9a-z\-][0-9a-z])\.(?'tld'[a-z]{2,}(?:\.[a-z]{2})?))|(?'ip'(?'segment'[01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9])\.(?&segment)\.(?&segment)\.(?&segment)))(?:\:(?'port'\d+))?(?'path'(?:\/[^\/\?]*?)*)?(?:\?(?'query'[^#]*))?(?:#!?(?'hash'.*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?\'protocol\'[a-z]{2,}(?=[:])):)?(?:\\\/\\\/)?(?:(?\'subdomain\'(?:[0-9a-z](?![\\-\\.]))+(?:[0-9a-z\\-\\.][0-9a-z]+)+?)\\.(?\'domain\'(?:[0-9a-z](?![\\-]))+(?:[0-9a-z\\-][0-9a-z])\\.(?\'tld\'[a-z]{2,}(?:\\.[a-z]{2})?))|(?\'ip\'(?\'segment\'[01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9])\\.(?&segment)\\.(?&segment)\\.(?&segment)))(?:\\:(?\'port\'\\d+))?(?\'path\'(?:\\\/[^\\\/\\?]*?)*)?(?:\\?(?\'query\'[^#]*))?(?:#!?(?\'hash\'.*))?$', 'gm')
const str = `ftp://regex101.billy.com.uk:3000/test/blah?hello=blah&#!/blah/blue/green
https://192.168.1.1/test/lab`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}