$re = '/^(?:(?\'protocol\'[a-z]{2,}(?=[:])):)?(?:\/\/)?(?:(?\'subdomain\'(?:[0-9a-z](?![\-\.]))+(?:[0-9a-z\-\.][0-9a-z]+)+?)\.(?\'domain\'(?:[0-9a-z](?![\-]))+(?:[0-9a-z\-][0-9a-z])\.(?\'tld\'[a-z]{2,}(?:\.[a-z]{2})?))|(?\'ip\'(?\'segment\'[01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9])\.(?&segment)\.(?&segment)\.(?&segment)))(?:\:(?\'port\'\d+))?(?\'path\'(?:\/[^\/\?]*?)*)?(?:\?(?\'query\'[^#]*))?(?:#!?(?\'hash\'.*))?$/m';
$str = 'ftp://regex101.billy.com.uk:3000/test/blah?hello=blah&#!/blah/blue/green
https://192.168.1.1/test/lab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);