// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$\{\$\{([\w-_\[\]]*?)\}\}|\$\{([\w-_\[\]]*?)\}|\$\{(((.*?)\})+)").unwrap();
let string = "
${${IP}${hi}${hello}${ab${cd}ef}${CUPM_IP}}
${LAST-NA[M]E}
${[BRACKETS]}
${CP_IM} ${b} ${1} ${} ${LAST-NAM[E]} ${12} ${34}${56} ${[BRACKETS]}
hello test b ${hg ${$} ${hello word} ${12-34_ab%}
${hg ${$}}
${${hi}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}