use strict;
my $str = '
${${IP}${hi}${hello}${ab${cd}ef}${CUPM_IP}}
${LAST-NA[M]E}
${[BRACKETS]}
${CP_IM} ${b} ${1} ${} ${LAST-NAM[E]} ${12} ${34}${56} ${[BRACKETS]}
hello test b ${hg ${$} ${hello word} ${12-34_ab%}
${hg ${$}}
${${hi}}';
my $regex = qr/\$\{\$\{([\w-_\[\]]*?)\}\}|\$\{([\w-_\[\]]*?)\}|\$\{(((.*?)\})+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}