import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\{\\$\\{([\\w-_\\[\\]]*?)\\}\\}|\\$\\{([\\w-_\\[\\]]*?)\\}|\\$\\{(((.*?)\\})+)";
final String string = "\n\n"
+ "${${IP}${hi}${hello}${ab${cd}ef}${CUPM_IP}}\n"
+ "${LAST-NA[M]E}\n"
+ "${[BRACKETS]}\n\n"
+ "${CP_IM} ${b} ${1} ${} ${LAST-NAM[E]} ${12} ${34}${56} ${[BRACKETS]}\n\n"
+ " hello test b ${hg ${$} ${hello word} ${12-34_ab%}\n\n"
+ "${hg ${$}}\n\n"
+ "${${hi}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}