const regex = /\$\{\$\{([\w-_\[\]]*?)\}\}|\$\{([\w-_\[\]]*?)\}|\$\{(((.*?)\})+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\{\\$\\{([\\w-_\\[\\]]*?)\\}\\}|\\$\\{([\\w-_\\[\\]]*?)\\}|\\$\\{(((.*?)\\})+)', 'g')
const str = `
\${\${IP}\${hi}\${hello}\${ab\${cd}ef}\${CUPM_IP}}
\${LAST-NA[M]E}
\${[BRACKETS]}
\${CP_IM} \${b} \${1} \${} \${LAST-NAM[E]} \${12} \${34}\${56} \${[BRACKETS]}
hello test b \${hg \${\$} \${hello word} \${12-34_ab%}
\${hg \${\$}}
\${\${hi}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}