re = /\$\{\$\{([\w-_\[\]]*?)\}\}|\$\{([\w-_\[\]]*?)\}|\$\{(((.*?)\})+)/
str = '
${${IP}${hi}${hello}${ab${cd}ef}${CUPM_IP}}
${LAST-NA[M]E}
${[BRACKETS]}
${CP_IM} ${b} ${1} ${} ${LAST-NAM[E]} ${12} ${34}${56} ${[BRACKETS]}
hello test b ${hg ${$} ${hello word} ${12-34_ab%}
${hg ${$}}
${${hi}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end