# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(\d+)\b"
test_str = ("\"18775551234\"\n"
"\"person\" <5551234>, \"text, might match an email\" <foo@bar.com>\n"
"\"SomeText\"\n"
"\"18775551234\", \"SomeText\", \"foo@bar.com\" <foo@bar.com>\n"
"\"foo@bar.com\"")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.